We have identified an issue affecting access to Retain settings and Metrics for some new Paddle Billing signups in the dashboard. A fix has been scheduled for deployment for new signups, and the access for sellers who signed up earlier is being gradually restored.
We apologize for any disruption this may have caused. If you have any questions or concerns, please contact us at sellers@paddle.com.
Identified
We have identified an issue affecting access to Retain settings and Metrics for some new Paddle Billing signups in the dashboard. A fix has been scheduled for deployment for new signups, and the access for sellers who signed up earlier is being gradually restored.
We apologize for any disruption this may have caused. If you have any questions or concerns, please contact us at sellers@paddle.com.
Investigating
We have identified an issue affecting new sellers’ access to the ProfitWell Metrics. We are actively working to resolve the root cause and restore normal service as soon as possible. We will update the status once a fix has been deployed.
We apologize for any disruption this may have caused. If you have any questions or concerns, please contact us at sellers@paddle.com.