The incident affecting Checkouts has been fully resolved. All services are now operating normally.
We apologize for any disruption this may have caused. If you have any questions or concerns, please contact our Customer Support team at sellers@paddle.com.
Resolved
The incident affecting Checkouts has been fully resolved. All services are now operating normally.
We apologize for any disruption this may have caused. If you have any questions or concerns, please contact our Customer Support team at sellers@paddle.com.
Monitoring
We have deployed a fix for the issue that was affecting Paddle Billing Checkouts. We are closely monitoring the platform to ensure continued stability.
We apologize for any disruption this may have caused. If you have any questions or concerns, please contact us at sellers@paddle.com.
Investigating
We are continuing to investigate the issue.
We appreciate your patience. Please reach out to our Customer Support team via sellers@paddle.com should you have any questions.
Identified
Our engineers are currently investigating an issue affecting checkout loading across Paddle Classic and Paddle Billing. This is causing some sellers to experience checkouts not loading as expected, and we are working to identify the root cause.
We will update the status as soon as we have more information.
We appreciate your patience. Please reach out to my team via sellers@paddle.com should you have any questions.