The incident affecting access to the Paddle seller dashboard sign-in has been fully resolved. All services are now operating normally.
We are closely monitoring the platform to ensure continued stability. We apologize for any disruption this may have caused.
If you have any questions or concerns, please contact our Customer Support team at sellers@paddle.com.
Resolved
The incident affecting access to the Paddle seller dashboard sign-in has been fully resolved. All services are now operating normally.
We are closely monitoring the platform to ensure continued stability. We apologize for any disruption this may have caused.
If you have any questions or concerns, please contact our Customer Support team at sellers@paddle.com.
Identified
We’ve identified an issue affecting access to the Paddle seller dashboard sign-in flow at vendors.paddle.com and sandbox-vendors.paddle.com, caused by a third-party incident.
Users who are already signed in are not affected. The issue is only impacting new sign-in attempts.
We apologize for any disruption this may have caused. If you have any questions or concerns, please contact us at sellers@paddle.com.