Paddle

Some customers were experiencing issues with ProfitWell
Resolved·Degraded performance

After a period of monitoring, the issue impacting the Profitwell web app and API has been fully resolved. The service continues to work as expected, so we are closing this incident.

We appreciate your patience and apologize for any disruption this may have caused. If you have any questions or concerns, please contact us at sellers@paddle.com.

Sun, Oct 5, 2025, 10:00 PM
(9 hours ago)
·
Affected components
Updates

Resolved

After a period of monitoring, the issue impacting the Profitwell web app and API has been fully resolved. The service continues to work as expected, so we are closing this incident.

We appreciate your patience and apologize for any disruption this may have caused. If you have any questions or concerns, please contact us at sellers@paddle.com.

Sun, Oct 5, 2025, 10:00 PM

Monitoring

Our engineers recently resolved an issue that affected the Profitwell web app and API, including the Paddle dashboard, Retain pages.
Widgets and payment recovery features remained fully functional.

We are actively monitoring the services to ensure stability and will provide updates here if any further action is required.
We apologize for any disruption this may have caused. If you have any questions or concerns, please contact us at sellers@paddle.com.

Fri, Oct 3, 2025, 11:44 AM(2 days earlier)
Powered by