Paddle

Some customers were experiencing issues with PayPal
Resolved·Degraded performance

The incident affecting PayPal payments has been fully resolved. All services are now operating normally. We apologize for any disruption this may have caused. If you have any questions or concerns, please contact our Customer Support team at sellers@paddle.com.

Thu, Oct 16, 2025, 05:47 PM
(2 days ago)
·
Affected components
Updates

Resolved

The incident affecting PayPal payments has been fully resolved. All services are now operating normally. We apologize for any disruption this may have caused. If you have any questions or concerns, please contact our Customer Support team at sellers@paddle.com.

Thu, Oct 16, 2025, 05:47 PM

Monitoring

The incident affecting PayPal payment processing for both Paddle Classic and Paddle Billing is now resolved. PayPal services are fully operational, and payments are going through successfully. The issue, which began around 15:22 UTC, was due to an outage on PayPal's end and briefly stopped payment processing, preventing customers from completing transactions using PayPal. We appreciate your patience during this time. If you have any questions or concerns, please contact our Customer Support team at sellers@paddle.com.

Thu, Oct 16, 2025, 05:29 PM(18 minutes earlier)

Monitoring

The incident affecting PayPal payment processing for both Paddle Classic and Paddle Billing is now resolved. PayPal services are fully operational, and payments are going through successfully. The issue, which began around 15:22 UTC, was due to an outage on PayPal's end and briefly stopped payment processing, preventing customers from completing transactions using PayPal. We appreciate your patience during this time. If you have any questions or concerns, please contact our Customer Support team at sellers@paddle.com.

Thu, Oct 16, 2025, 05:13 PM(15 minutes earlier)

Investigating

Our engineers are currently investigating an issue with the payment method PayPal for both Paddle Classic and Paddle Billing for both checkout and subscription payments due to an outage on PayPal's end. PayPal payment processing has stopped in the production environment, preventing customers from completing transactions using PayPal. The issue began around 15:22 UTC and is ongoing, with only brief periods of successful processing. Buyers who are trying to checkout via PayPal will receive an error which states: "unable to take payment, please try another payment method". Other payment methods remain unaffected. We will update here with more information.

Thu, Oct 16, 2025, 03:53 PM(1 hour earlier)
Powered by