Paddle

Some customers are experiencing issues
Resolved·Degraded performance

All services have returned to normal following the Cloudflare incident this morning. Our engineers will continue to monitor our services, but we do not expect any further problems.

Fri, Dec 5, 2025, 09:45 AM
(1 week ago)
·
Affected components
Updates

Resolved

All services have returned to normal following the Cloudflare incident this morning. Our engineers will continue to monitor our services, but we do not expect any further problems.

Fri, Dec 5, 2025, 09:45 AM

Monitoring

Services are now operational. We are closely monitoring the platform to ensure continued stability. We apologize for any disruption this may have caused.

We apologize for any disruption this may have caused. If you have any questions or concerns, please contact us at sellers@paddle.com

Fri, Dec 5, 2025, 09:16 AM(29 minutes earlier)

Investigating

Our engineers are currently investigating an issue affecting some of our services. We will update the status as soon as we have more information. We appreciate your patience. Please reach out to our Customer Support team via sellers@paddle.com should you have any questions.

Fri, Dec 5, 2025, 08:59 AM(16 minutes earlier)
Powered by