Paddle

Delayed notifications
Resolved·Partial outage

After a period of monitoring, we can confirm that the issue causing the delayed delivery of notifications has been fully resolved, and all notifications have been processed. Between 01.09am and 02.06am GMT we experienced delays in the delivery of notifications for both webhooks and emails to buyers. During the incident we saw an average delay of around 20 minutes for these notifications. No notifications were lost and all were processed once the issue was resolved. We apologize for any disruption this may have caused. If you have any questions or concerns, please contact us at sellers@paddle.com.

Thu, Dec 11, 2025, 09:16 AM
(2 months ago)
·
Affected components
Updates

Resolved

After a period of monitoring, we can confirm that the issue causing the delayed delivery of notifications has been fully resolved, and all notifications have been processed. Between 01.09am and 02.06am GMT we experienced delays in the delivery of notifications for both webhooks and emails to buyers. During the incident we saw an average delay of around 20 minutes for these notifications. No notifications were lost and all were processed once the issue was resolved. We apologize for any disruption this may have caused. If you have any questions or concerns, please contact us at sellers@paddle.com.

Thu, Dec 11, 2025, 09:16 AM

Monitoring

The issue causing the delayed delivery of notifications has now been resolved, and all notifications have been processed.

We apologize for any disruption this may have caused. If you have any questions or concerns, please contact us at sellers@paddle.com.

Thu, Dec 11, 2025, 02:10 AM(7 hours earlier)

Investigating

Our engineers are currently investigating an issue affecting notifications. This is causing delayed delivery of webhooks and emails, and we are working to identify the root cause. We will update the status as soon as we have more information.

We appreciate your patience. Please reach out to our Customer Support team via sellers@paddle.com should you have any questions.

Thu, Dec 11, 2025, 02:00 AM
Powered by