The incident affecting Retain has been resolved, and service has recovered.
We will continue monitoring to ensure everything remains stable. If you have any questions, please contact our Customer Support team at sellers@paddle.com.
Resolved
The incident affecting Retain has been resolved, and service has recovered.
We will continue monitoring to ensure everything remains stable. If you have any questions, please contact our Customer Support team at sellers@paddle.com.
Resolved
The incident affecting Retain has been fully resolved. All services are now operating normally. We will continue to monitor for the next 24 hours to ensure stability.
During the incident between 2:56 PM UTC and 3:25 PM UTC, the following areas may have been affected:
Metrics dashboard
Payment retries
Dunning emails
Cancelling past-due subscriptions
Cancellation flows not rendering correctly (Customer Portal fell back to the default cancellation modal)
The Retain section in the Paddle Billing dashboard
We apologize for any disruption this may have caused. If you have any questions or concerns, please contact our Customer Support team at sellers@paddle.com.
Investigating
Our engineers are currently investigating an issue affecting Retain. This is causing some service disruption, and we are working to identify the root cause. We will update the status as soon as we have more information.
We appreciate your patience. Please reach out to our Customer Support team via sellers@paddle.com should you have any questions.