The incident affecting report downloads in the Paddle Dashboard has been fully resolved. Our engineers deployed a fix, and the generated reports can now be downloaded as expected.
We apologize for any disruption this may have caused. If you have any questions or concerns, please contact our Customer Support team at sellers@paddle.com.
Resolved
The incident affecting report downloads in the Paddle Dashboard has been fully resolved. Our engineers deployed a fix, and the generated reports can now be downloaded as expected.
We apologize for any disruption this may have caused. If you have any questions or concerns, please contact our Customer Support team at sellers@paddle.com.
Investigating
Our engineers are currently investigating an issue affecting report downloads in the Paddle Dashboard. Some users may encounter an error when attempting to download generated reports. We are working to identify the root cause and restore normal service as soon as possible.
We’ll provide another update when more information is available.
We appreciate your patience. Please reach out to our Customer Support team via sellers@paddle.com should you have any questions.